Re: Preparing an .HDF file

It should be already, 60 HZ, 30KHz by default.

Re: Preparing an .HDF file

My monitor says 15.6 kHz, 49.9 Hz, denying to display...

Can still be that I did something wrong, I started putting all in a sub folder but now its in the sdcard main.

Re: Preparing an .HDF file

Shouldn't matter. It says 15.6 kHz after you select "load target" and the rApp.ini file?

Re: Preparing an .HDF file

yap

Re: Preparing an .HDF file

ah, yes it comes up in 50HZ. That's odd.

Re: Preparing an .HDF file

arrgghh I see the problem.
Wolfgang only sends the static, not the dynamic config over when launching an ini file.
mmmmm
let me ponder for a mo

Re: Preparing an .HDF file

Cool! I will be in New-Year party mode any moment, so I will do further tests next days, but I really appreciate your help wink

Re: Preparing an .HDF file

Ok, flipped the defaults - now 60hz progressive should happen. If anybody can't cope with this I'll provide a custom fix.

Post's attachments

rAppFlashUpdater_30Dec2015.zip 218.98 kb, 16 downloads since 2015-12-30 

You don't have the permssions to download the attachments of this post.

84 (edited by JimDrew 2015-12-30 22:34:08)

Re: Preparing an .HDF file

My DVI monitor was all screwy with the .ini (and the previous version), showing "blurry" text.  R also didn't reboot like all previous flashers did.

Re: Preparing an .HDF file

yeah I noticed R didn't reboot. What do you mean by "blurry"? Can you confirm the standard is 60Hz 30K?
Works fine over DVI for me.

Re: Preparing an .HDF file

I will try the new one.

Re: Preparing an .HDF file

I just did a quick test. Firmware update now works great. Also, I can mount the hardfile now.

Still, I have some issues with my setup but this bug is fixed.. thanks

Re: Preparing an .HDF file

MikeJ - would you recommend this update for everyone, or hold off for now?

Re: Preparing an .HDF file

Only change is in the HDF index for 4G files. No need to take it unless you have an issue.

Re: Preparing an .HDF file

As I already suspected, there seems to be still an issue left...

It is not reproducable with the empty 4G hardfile I sent you. But, of course, I also have a 4G hardfile filled with data. With this, I still have weird behaviour:

1) Mount the filled 4G hardfile as second HD, boot workbench from first
2) Everything comes up fine
3) Reset Target, from now on 4G hardfile cannot be accessed, Workbench throws an "Device xyz: Rootblock extension invalid" error.

Note that I did not do anything with the 4G harddisk, just booting up Workbench. Seems that mounting it breaks things.

Comparing the hdf file before it gets broken and afterwards, there are a few single bytes changed around position 0x40400-0x40F00

Of course I can elaborate on this, I could either send my the hardfile (2G packed) or tell you about the bytes which have actually changed.

Re: Preparing an .HDF file

Can you do the same test with the cache off? there is a known issue (snoop) with the released code I am working on.

Re: Preparing an .HDF file

Sorry, I totally fortgot to tell you which core I used wink

I used the core from post #1224 http://www.fpgaarcade.com/punbb/viewtop … 7462#p7462

The ini file is taken from post #989 with minimal changes (mostly ntsc->pal)
I do not see that there are any cache options enabled.
Also, I had similiar results using an older core with definitly no cache support.

Re: Preparing an .HDF file

Ok. The cache is enabled when the speed is "turbo+cache". Change to "FAST  ~28MHz" to disable the cache if you haven't already.

Or wait a little for the new core with a fix hopefully.....

Re: Preparing an .HDF file

>item = "CPU Speed",      0x00000300,dynamic
>option = "A500   ~7MHz", 0x00000000
>option = "A1200 ~14MHz", 0x00000100
>option = "FAST  ~28MHz", 0x00000200,default
>option = "Turbo+Cache",  0x00000300

I did not toggle anything about cache...

Re: Preparing an .HDF file

You may find the later core with everything back in again works better for you - but suggest wait a little, we are looking at some other CPU issues.